Enhanced Goto dialog enhancement

 Delphi, GExperts  Comments Off on Enhanced Goto dialog enhancement
Feb 042017
 

The Goto dialog IDE enhancement of GExperts got itself an enhancement:

It now also displays “Package”, “Requires” and “Contains” in the list.

Also, all IDE dialog enhancement classes now derive from a new TIdeDialogEnhancer class which provides some basic functionality that previously was duplicated.

 Posted by on 2017-02-04 at 20:31

New IDE enhancement for the Application settings

 Delphi, GExperts  Comments Off on New IDE enhancement for the Application settings
Feb 042017
 

GExperts now has got a very small enhancement for the Application tab in the project settings dialog of the Delphi IDE:

A new button that sets the lib suffix to the default value corresponding to the IDE version which is showing this dialog (example: Delphi 2007 -> 110, Delphi 10.1 -> 240).

This is only really useful for those who develop packages for multiple Delphi versions and like me always forget, which suffix to use for which Delphi version.

Of course it would be nice to have that set automatically for new package projects. Anybody who wants to contribute code for that?

 Posted by on 2017-02-04 at 20:00